On Thu, Feb 10, 2011 at 03:09:42PM +0000, Mel Gorman wrote: > On Thu, Feb 10, 2011 at 07:01:55AM -0800, Dave Hansen wrote: > > On Thu, 2011-02-10 at 11:20 +0000, Mel Gorman wrote: > > > > @@ -394,6 +395,7 @@ static int smaps_pte_range(pmd_t *pmd, u > > > > spin_lock(&walk->mm->page_table_lock); > > > > } else { > > > > smaps_pte_entry(*(pte_t *)pmd, addr, HPAGE_SIZE, walk); > > > > + mss->anonymous_thp += HPAGE_SIZE; > > > > > > I should have thought of this for the previous patch but should this be > > > HPAGE_PMD_SIZE instead of HPAGE_SIZE? Right now, they are the same value > > > but they are not the same thing. > > > > Probably. There's also a nice BUG() in HPAGE_PMD_SIZE if the THP config > > option is off, which is an added bonus. > > > > Unless Andrea has an objection, I'd prefer to see HPAGE_PMD_SIZE. We get there only through pmd_trans_huge, so HPAGE_PMD_SIZE is certainly more correct, agreed. I also think this can go in -mm after s/HPAGE_SIZE/HPAGE_PMD_SIZE/ and after correcting the locking (see other email). Maybe it'd be cleaner if we didn't need to cast the pmd to pte_t but I guess this makes things simpler. Thanks! Andrea -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>