On Wed, 7 Feb 2018 10:47:02 -0600 (CST) Christopher Lameter <cl@xxxxxxxxx> wrote: > On Tue, 6 Feb 2018, Matthew Wilcox wrote: > > > Personally, I would like us to rename kvfree() to just free(), and have > > malloc(x) be an alias to kvmalloc(x, GFP_KERNEL), but I haven't won that > > fight yet. > > Maybe lets implement malloc(), free() and realloc() in the kernel to be > consistent with user space use as possible? Only use the others > allocation variants for special cases. They would need to drop the GFP part and default to GFP_KERNEL. > > So malloc would check allocation sizes and if < 2* PAGE_SIZE use kmalloc() > otherwise vmalloc(). Please no, I hate subtle internal decisions like this. It makes debugging much more difficult, when allocating dynamic sized variables. When something works at one size but not the other. -- Steve > > free() would free anything you give it. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>