Re: [PATCH v2 5/5] mm: Rename zone_statistics() to numa_statistics()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue 19-12-17 14:39:26, Kemi Wang wrote:
> Since the functionality of zone_statistics() updates numa counters, but
> numa statistics has been separated from zone statistics framework. Thus,
> the function name makes people confused. So, change the name to
> numa_statistics() as well as its call sites accordingly.
> 
> Signed-off-by: Kemi Wang <kemi.wang@xxxxxxxxx>

Acked-by: Michal Hocko <mhocko@xxxxxxxx>

> ---
>  mm/page_alloc.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/mm/page_alloc.c b/mm/page_alloc.c
> index 81e8d8f..f7583de 100644
> --- a/mm/page_alloc.c
> +++ b/mm/page_alloc.c
> @@ -2790,7 +2790,7 @@ int __isolate_free_page(struct page *page, unsigned int order)
>   *
>   * Must be called with interrupts disabled.
>   */
> -static inline void zone_statistics(struct zone *preferred_zone, struct zone *z)
> +static inline void numa_statistics(struct zone *preferred_zone, struct zone *z)
>  {
>  #ifdef CONFIG_NUMA
>  	int preferred_nid = preferred_zone->node;
> @@ -2854,7 +2854,7 @@ static struct page *rmqueue_pcplist(struct zone *preferred_zone,
>  	page = __rmqueue_pcplist(zone,  migratetype, pcp, list);
>  	if (page) {
>  		__count_zid_vm_events(PGALLOC, page_zonenum(page), 1 << order);
> -		zone_statistics(preferred_zone, zone);
> +		numa_statistics(preferred_zone, zone);
>  	}
>  	local_irq_restore(flags);
>  	return page;
> @@ -2902,7 +2902,7 @@ struct page *rmqueue(struct zone *preferred_zone,
>  				  get_pcppage_migratetype(page));
>  
>  	__count_zid_vm_events(PGALLOC, page_zonenum(page), 1 << order);
> -	zone_statistics(preferred_zone, zone);
> +	numa_statistics(preferred_zone, zone);
>  	local_irq_restore(flags);
>  
>  out:
> -- 
> 2.7.4
> 

-- 
Michal Hocko
SUSE Labs

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]
  Powered by Linux