On Fri 20-10-17 15:22:14, Xishi Qiu wrote: > On 2017/10/20 10:13, Joonsoo Kim wrote: > > > On Thu, Oct 19, 2017 at 02:21:18PM +0200, Michal Hocko wrote: [...] > >> >From 8cbd811d741f5dd93d1b21bb3ef94482a4d0bd32 Mon Sep 17 00:00:00 2001 > >> From: Michal Hocko <mhocko@xxxxxxxx> > >> Date: Thu, 19 Oct 2017 14:14:02 +0200 > >> Subject: [PATCH] mm: distinguish CMA and MOVABLE isolation in > >> has_unmovable_pages > >> > >> Joonsoo has noticed that "mm: drop migrate type checks from > >> has_unmovable_pages" would break CMA allocator because it relies on > >> has_unmovable_pages returning false even for CMA pageblocks which in > >> fact don't have to be movable: > >> alloc_contig_range > >> start_isolate_page_range > >> set_migratetype_isolate > >> has_unmovable_pages > >> > >> This is a result of the code sharing between CMA and memory hotplug > >> while each one has a different idea of what has_unmovable_pages should > >> return. This is unfortunate but fixing it properly would require a lot > >> of code duplication. > >> > >> Fix the issue by introducing the requested migrate type argument > >> and special case MIGRATE_CMA case where CMA page blocks are handled > >> properly. This will work for memory hotplug because it requires > >> MIGRATE_MOVABLE. > > > > Unfortunately, alloc_contig_range() can be called with > > MIGRATE_MOVABLE so this patch cannot perfectly fix the problem. > > > > I did a more thinking and found that it's strange to check if there is > > unmovable page in the pageblock during the set_migratetype_isolate(). > > set_migratetype_isolate() should be just for setting the migratetype > > of the pageblock. Checking other things should be done by another > > place, for example, before calling the start_isolate_page_range() in > > __offline_pages(). > > > > Thanks. > > > > Hi Joonsoo, > > How about add a flag to skip or not has_unmovable_pages() in set_migratetype_isolate()? > Something like the skip_hwpoisoned_pages. I believe this is what Joonsoo was proposing actually. I cannot say I would like skip_hwpoisoned_pages and adding one more flag is just too ugly. So I would prefer to have something that would actually make sense from the semantic POV. If CMA really needs to work with partial CMA blocks then MIGRATE_CMA as an indicator sounds like the right way to go to me. But I am not a CMA expert so I might be missing some subtlety here. -- Michal Hocko SUSE Labs -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>