Re: [PATCH] vmalloc: add __alloc_vm_area() for optimizing vmap stack

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This looks fine in general, but a few comments:

 - can you split adding the new function from switching over the fork
   code?
 - at least kasan and vmalloc_user/vmalloc_32_user use very similar
   patterns, can you switch them over as well?
 - the new __alloc_vm_area looks very different from alloc_vm_area,
   maybe it needs a better name?  vmalloc_range_area for example?
 - when you split an existing function please keep the more low-level
   function on top of the higher level one that calls it.

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@xxxxxxxxx.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@xxxxxxxxx";> email@xxxxxxxxx </a>



[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]
  Powered by Linux