On Mon, Aug 07, 2017 at 04:12:52PM +0900, Byungchul Park wrote: > diff --git a/include/linux/lockdep.h b/include/linux/lockdep.h > index fffe49f..0c8a1b8 100644 > --- a/include/linux/lockdep.h > +++ b/include/linux/lockdep.h > @@ -467,6 +520,49 @@ static inline void lockdep_on(void) > > #endif /* !LOCKDEP */ > > +enum context_t { > + HARD, > + SOFT, > + PROC, > + CONTEXT_NR, > +}; Since this is the global namespace and those being somewhat generic names, I've renamed the lot: +enum xhlock_context_t { + XHLOCK_HARD, + XHLOCK_SOFT, + XHLOCK_PROC, + XHLOCK_NR, +}; -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>