On 09/08/2017 12:08, Kirill A. Shutemov wrote: > On Tue, Aug 08, 2017 at 04:35:35PM +0200, Laurent Dufour wrote: >> @@ -2295,7 +2302,11 @@ static int wp_page_copy(struct vm_fault *vmf) >> /* >> * Re-check the pte - we dropped the lock >> */ >> - vmf->pte = pte_offset_map_lock(mm, vmf->pmd, vmf->address, &vmf->ptl); >> + if (!pte_map_lock(vmf)) { >> + mem_cgroup_cancel_charge(new_page, memcg, false); >> + ret = VM_FAULT_RETRY; >> + goto oom_free_new; > > With the change, label is misleading. That's right. But I'm wondering renaming it out to 'out_free_new' and replacing all the matching 'goto' where the label was making sense will help readability ? Have you better idea ? -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>