On Tue, Apr 04, 2017 at 06:01:48PM -0400, Johannes Weiner wrote: > The memory controllers stat function names are awkwardly long and > arbitrarily different from the zone and node stat functions. > > The current interface is named: > > mem_cgroup_read_stat() > mem_cgroup_update_stat() > mem_cgroup_inc_stat() > mem_cgroup_dec_stat() > mem_cgroup_update_page_stat() > mem_cgroup_inc_page_stat() > mem_cgroup_dec_page_stat() > > This patch renames it to match the corresponding node stat functions: > > memcg_page_state() [node_page_state()] > mod_memcg_state() [mod_node_state()] > inc_memcg_state() [inc_node_state()] > dec_memcg_state() [dec_node_state()] > mod_memcg_page_state() [mod_node_page_state()] > inc_memcg_page_state() [inc_node_page_state()] > dec_memcg_page_state() [dec_node_page_state()] > > Signed-off-by: Johannes Weiner <hannes@xxxxxxxxxxx> Looks neat. Acked-by: Vladimir Davydov <vdavydov.dev@xxxxxxxxx> -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>