As suggested by Johannes, rename reclaim_mode to reclaim_mode_t. This is a fix to the mmotm patch broken-out/mm-vmscan-rename-lumpy_mode-to-reclaim_mode.patch. Signed-off-by: Mel Gorman <mel@xxxxxxxxx> --- mm/vmscan.c | 16 ++++++++-------- 1 files changed, 8 insertions(+), 8 deletions(-) diff --git a/mm/vmscan.c b/mm/vmscan.c index 42a4859..a9390fd 100644 --- a/mm/vmscan.c +++ b/mm/vmscan.c @@ -63,12 +63,12 @@ * RECLAIM_MODE_COMPACTION: For high-order allocations, reclaim a number of * order-0 pages and then compact the zone */ -typedef unsigned __bitwise__ reclaim_mode; -#define RECLAIM_MODE_SINGLE ((__force reclaim_mode)0x01u) -#define RECLAIM_MODE_ASYNC ((__force reclaim_mode)0x02u) -#define RECLAIM_MODE_SYNC ((__force reclaim_mode)0x04u) -#define RECLAIM_MODE_LUMPYRECLAIM ((__force reclaim_mode)0x08u) -#define RECLAIM_MODE_COMPACTION ((__force reclaim_mode)0x10u) +typedef unsigned __bitwise__ reclaim_mode_t; +#define RECLAIM_MODE_SINGLE ((__force reclaim_mode_t)0x01u) +#define RECLAIM_MODE_ASYNC ((__force reclaim_mode_t)0x02u) +#define RECLAIM_MODE_SYNC ((__force reclaim_mode_t)0x04u) +#define RECLAIM_MODE_LUMPYRECLAIM ((__force reclaim_mode_t)0x08u) +#define RECLAIM_MODE_COMPACTION ((__force reclaim_mode_t)0x10u) struct scan_control { /* Incremented by the number of inactive pages that were scanned */ @@ -101,7 +101,7 @@ struct scan_control { * Intend to reclaim enough continuous memory rather than reclaim * enough amount of memory. i.e, mode for high order allocation. */ - reclaim_mode reclaim_mode; + reclaim_mode_t reclaim_mode; /* Which cgroup do we reclaim from */ struct mem_cgroup *mem_cgroup; @@ -287,7 +287,7 @@ unsigned long shrink_slab(unsigned long scanned, gfp_t gfp_mask, static void set_reclaim_mode(int priority, struct scan_control *sc, bool sync) { - reclaim_mode syncmode = sync ? RECLAIM_MODE_SYNC : RECLAIM_MODE_ASYNC; + reclaim_mode_t syncmode = sync ? RECLAIM_MODE_SYNC : RECLAIM_MODE_ASYNC; /* * Initially assume we are entering either lumpy reclaim or -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom policy in Canada: sign http://dissolvethecrtc.ca/ Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>