On Sun 19-03-17 23:03:45, Wei Yang wrote: > On Sun, Mar 19, 2017 at 10:30:13AM -0400, Michal Hocko wrote: > >On Sat 18-03-17 08:39:14, Wei Yang wrote: > >> The field page->flags is defined as unsigned long and is divided into > >> several parts to store different information of the page, like section, > >> node, zone. Which means all parts must sit in the one "unsigned > >> long". > >> > >> BITS_PER_LONG is used in several places to ensure this applies. > >> > >> #if SECTIONS_WIDTH+NODES_WIDTH+ZONES_WIDTH > BITS_PER_LONG - NR_PAGEFLAGS > >> #if SECTIONS_WIDTH+ZONES_WIDTH+NODES_SHIFT <= BITS_PER_LONG - NR_PAGEFLAGS > >> #if SECTIONS_WIDTH+ZONES_WIDTH+NODES_SHIFT+LAST_CPUPID_SHIFT <= BITS_PER_LONG - NR_PAGEFLAGS > >> > >> While we use "sizeof(unsigned long) * 8" in the definition of > >> SECTIONS_PGOFF > >> > >> #define SECTIONS_PGOFF ((sizeof(unsigned long)*8) - SECTIONS_WIDTH) > >> > >> This may not be that obvious for audience to catch the point. > >> > >> This patch replaces the "sizeof(unsigned long) * 8" with BITS_PER_LONG to > >> make all this consistent. > > > >I am not really sure this is an improvement. page::flags is unsigned > >long nad the current code reflects that type. > > > > Hi, Michal > > Glad to hear from you. > > I think the purpose of definition BITS_PER_LONG is more easily to let audience > know it is the number of bits of type long. If it has no improvement, we don't > need to define a specific macro . > > And as you could see, several related macros use BITS_PER_LONG in their > definition. After this change, all of them will have a consistent definition. > > After this change, code looks more neat :-) > > So it looks more reasonable to use this. I do not think that this is sufficient to justify the change. -- Michal Hocko SUSE Labs -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>