Just a couple of trivial memblock patches, which could also be merged into one patch; whatever is preferred. Since commit 70210ed950b5 ("mm/memblock: add physical memory list") the memblock structure knows about a physical memory list. The memblock code should also print a sane name instead of "unknown" if it calls memblock_type_name() to get a name for the physmem memblock type. In addition the physmem list should also be dumped, if present, and memblock_dump_all is called to improve debugability. The last patch embeds the memblock type name into the memblock type structure in order to hopefully make the code a bit more easier and to get rid of a bit of code duplication. Thanks, Heiko Heiko Carstens (3): memblock: let memblock_type_name know about physmem type memblock: also dump physmem list within __memblock_dump_all memblock: embed memblock type name within struct memblock_type arch/s390/kernel/crash_dump.c | 1 + include/linux/memblock.h | 1 + mm/memblock.c | 32 +++++++++++++------------------- 3 files changed, 15 insertions(+), 19 deletions(-) -- 2.8.4 -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>