Hi, These patches add notification of madvise(MADV_REMOVE) event to non-cooperative userfaultfd monitor. The first pacth renames EVENT_MADVDONTNEED to EVENT_REMOVE along with relevant functions and structures. Using _REMOVE instead of _MADVDONTNEED describes the event semantics more clearly and I hope it's not too late for such change in the ABI. The patches are against current -mm tree. Mike Rapoport (3): userfaultfd: non-cooperative: rename *EVENT_MADVDONTNEED to *EVENT_REMOVE userfaultfd: non-cooperative: add madvise() event for MADV_REMOVE request userfaultfd: non-cooperative: selftest: enable REMOVE event test for shmem fs/userfaultfd.c | 14 +++++++------- include/linux/userfaultfd_k.h | 16 ++++++++-------- include/uapi/linux/userfaultfd.h | 8 ++++---- mm/madvise.c | 3 ++- tools/testing/selftests/vm/userfaultfd.c | 22 ++++++++++------------ 5 files changed, 31 insertions(+), 32 deletions(-) -- 1.9.1 -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>