On (01/13/17 15:47), Minchan Kim wrote: [..] > > > Could you elaborate a bit? Do you mean this? > > > > > > ret = scnprintf(buf, PAGE_SIZE, > > > "%8llu %8llu %8llu %8lu %8ld %8llu %8lu\n", > > > orig_size << PAGE_SHIFT, > > > (u64)atomic64_read(&zram->stats.compr_data_size), > > > mem_used << PAGE_SHIFT, > > > zram->limit_pages << PAGE_SHIFT, > > > max_used << PAGE_SHIFT, > > > // (u64)atomic64_read(&zram->stats.zero_pages), > > > (u64)atomic64_read(&zram->stats.same_pages), > > > pool_stats.pages_compacted); > > > > yes, correct. > > > > do we need to export it as two different stats (zero_pages and > > same_pages), if those are basically same thing internally? > > So, let summary up. > > 1. replace zero_page stat into same page stat in mm_stat > 2. s/zero_pages/same_pages/Documentation/blockdev/zram.txt > 3. No need to warn to "cat /sys/block/zram0/mm_stat" user to see zero_pages > about semantic change 1) account zero_page and same_pages in one attr. this already is in the patch. 2) do not rename zero_pages attr. we can't do this so fast, I think. > 3. No need to warn to "cat /sys/block/zram0/mm_stat" user to see zero_pages > about semantic change yes. we just _may_ have more pages (depending on data pattern) which we treat as "zero" pages internally. this results in lower memory consumption. I don't think warn users about this change is necessary; they won't be able to do anything about it anyway. zero_pages stat is pretty much just a fun number to know. isn't it? or do you think that we should account it in separate stats? -ss -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>