On 11/28/2016 12:40 AM, Aaron Lu wrote: > As suggested by Linus, the same mmu gather logic could be used for tlb > flush in mremap and this patch just did that. > > Note that since there is no page added to "struct mmu_gather" for free > during mremap, when tlb needs to be flushed, we can use tlb_flush_mmu or > tlb_flush_mmu_tlbonly. Using tlb_flush_mmu could also avoid exporting > tlb_flush_mmu_tlbonly. But tlb_flush_mmu_tlbonly *looks* more clear and > straightforward so I end up using it. OK, so the code before this patch was passing around a pointer to 'need_flush', and we basically just pass around an mmu_gather instead. It doesn't really simplify the code _too_ much, although it does make it less confusing than when we saw 'need_flush' mixed with 'force_flush' in the code. tlb_flush_mmu_tlbonly() has exactly one other use: zap_pte_range() for flushing the TLB before pte_unmap_unlock(): if (force_flush) tlb_flush_mmu_tlbonly(tlb); pte_unmap_unlock(start_pte, ptl); But, both call-sites are still keeping 'force_flush' to store the information about whether we ever saw a dirty pte. If we moved _that_ logic into the x86 mmu_gather code, we could get rid of all the 'force_flush' tracking in both call sites. It also makes us a bit more future-proof against these page_mkclean() races if we ever grow a third site for clearing ptes. Instead of exporting and calling tlb_flush_mmu_tlbonly(), we'd need something like tlb_flush_mmu_before_ptl_release() (but with a better name, of course :). -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>