On Wed, 2016-03-23 at 10:26 +0800, Yaowei Bai wrote: > This patch makes is_file/active_lru return bool to improve > readability due to these particular functions only using either > one or zero as their return value. > > No functional change. These assignments to int should likely be modified too $ git grep -w -n is_file_lru include/linux/mmzone.h:191:static inline int is_file_lru(enum lru_list lru) mm/vmscan.c:1404: nr_taken, mode, is_file_lru(lru)); mm/vmscan.c:1525: int file = is_file_lru(lru); mm/vmscan.c:1581: int file = is_file_lru(lru); mm/vmscan.c:1783: int file = is_file_lru(lru); mm/vmscan.c:1934: if (is_file_lru(lru)) mm/vmscan.c:2129: int file = is_file_lru(lru); -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>