On Tue, Mar 22, 2016 at 01:56:26PM -0400, Johannes Weiner wrote: > On Tue, Mar 22, 2016 at 02:22:49PM +0100, Peter Zijlstra wrote: > > On Tue, Mar 22, 2016 at 02:08:23PM +0100, Michal Hocko wrote: > > > On Tue 22-03-16 13:51:13, Peter Zijlstra wrote: > > > If that sounds like a more appropriate plan I won't object. I can simply > > > change my patch to do __set_current_state and schedule_timeout. > > > > I dunno, I just think these wrappers are silly. > > Adding out-of-line, exported wrappers for every single task state is > kind of silly. But it's still a common operation to wait in a certain > state, so having a single function for that makes sense. Kind of like > spin_lock_irqsave and friends. > > Maybe this would be better?: > > static inline long schedule_timeout_state(long timeout, long state) > { > __set_current_state(state); > return schedule_timeout(timeout); > } Probably. However, with such semantics the schedule*() name is wrong too, you cannot use these functions to build actual wait loops etc. So maybe: static inline long sleep_in_state(long timeout, long state) { __set_current_state(state); return schedule_timeout(timeout); } might be an even better name; but at that point we look very like the msleep*() class of function, so maybe we should do: long sleep_in_state(long state, long timeout) { while (timeout && !signal_pending_state(state, current)) { __set_current_state(state); timeout = schedule_timeout(timeout); } return timeout; } Hmm ? -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>