On Mon, Mar 21, 2016 at 04:13:43PM +0900, Chulmin Kim wrote: > On 2016년 03월 21일 15:30, Minchan Kim wrote: > >Procedure of page migration is as follows: > > > >First of all, it should isolate a page from LRU and try to > >migrate the page. If it is successful, it releases the page > >for freeing. Otherwise, it should put the page back to LRU > >list. > > > >For LRU pages, we have used putback_lru_page for both freeing > >and putback to LRU list. It's okay because put_page is aware of > >LRU list so if it releases last refcount of the page, it removes > >the page from LRU list. However, It makes unnecessary operations > >(e.g., lru_cache_add, pagevec and flags operations. It would be > >not significant but no worth to do) and harder to support new > >non-lru page migration because put_page isn't aware of non-lru > >page's data structure. > > > >To solve the problem, we can add new hook in put_page with > >PageMovable flags check but it can increase overhead in > >hot path and needs new locking scheme to stabilize the flag check > >with put_page. > > > >So, this patch cleans it up to divide two semantic(ie, put and putback). > >If migration is successful, use put_page instead of putback_lru_page and > >use putback_lru_page only on failure. That makes code more readable > >and doesn't add overhead in put_page. > > > >Comment from Vlastimil > >"Yeah, and compaction (perhaps also other migration users) has to drain > >the lru pvec... Getting rid of this stuff is worth even by itself." > > > >Cc: Mel Gorman <mgorman@xxxxxxx> > >Cc: Hugh Dickins <hughd@xxxxxxxxxx> > >Cc: Naoya Horiguchi <n-horiguchi@xxxxxxxxxxxxx> > >Acked-by: Vlastimil Babka <vbabka@xxxxxxx> > >Signed-off-by: Minchan Kim <minchan@xxxxxxxxxx> > >--- > > mm/migrate.c | 50 +++++++++++++++++++++++++++++++------------------- > > 1 file changed, 31 insertions(+), 19 deletions(-) > > > >diff --git a/mm/migrate.c b/mm/migrate.c > >index 6c822a7b27e0..b65c84267ce0 100644 > >--- a/mm/migrate.c > >+++ b/mm/migrate.c > >@@ -913,6 +913,14 @@ static int __unmap_and_move(struct page *page, struct page *newpage, > > put_anon_vma(anon_vma); > > unlock_page(page); > > out: > >+ /* If migration is scucessful, move newpage to right list */ > > A minor comment fix :) > + /* If migration is successful, move newpage to right list */ Hello Chulmin, Fixed the typo. Thanks for the review! -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href