On 02/29, Michal Hocko wrote: > > On Mon 29-02-16 18:23:34, Oleg Nesterov wrote: > > On 02/29, Michal Hocko wrote: > > > > > > @@ -267,7 +267,10 @@ static int __bprm_mm_init(struct linux_binprm *bprm) > > > if (!vma) > > > return -ENOMEM; > > > > > > - down_write(&mm->mmap_sem); > > > + if (down_write_killable(&mm->mmap_sem)) { > > > + err = -EINTR; > > > + goto err_free; > > > + } > > > vma->vm_mm = mm; > > > > I won't argue, but this looks unnecessary. Nobody else can see this new mm, > > down_write() can't block. > > > > In fact I think we can just remove down_write/up_write here. Except perhaps > > there is lockdep_assert_held() somewhere in these paths. > > This is what I had initially but then I've noticed that mm_alloc() does > mm_init(current)->init_new_context(current) yes, and init_new_context() is arch dependant... > code doesn't seem much harder to follow, the callers are already > handling all error paths so I guess it would be better to simply move on > this. Yes, agreed, please forget. Oleg. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxx. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>