> > @@ -2628,16 +2628,16 @@ static int __zone_reclaim(struct zone *zone, gfp_t gfp_mask, unsigned int order) > > * take a long time. > > */ > > while (shrink_slab(sc.nr_scanned, gfp_mask, order) && > > - zone_page_state(zone, NR_SLAB_RECLAIMABLE) > > > - slab_reclaimable - nr_pages) > > + (zone_page_state(zone, NR_SLAB_RECLAIMABLE) + nr_pages > n)) > > ; > > > > /* > > * Update nr_reclaimed by the number of slab pages we > > * reclaimed from this zone. > > */ > > - sc.nr_reclaimed += slab_reclaimable - > > - zone_page_state(zone, NR_SLAB_RECLAIMABLE); > > + m = zone_page_state(zone, NR_SLAB_RECLAIMABLE); > > + if (m < n) > > + sc.nr_reclaimed += n - m; > > And it's not a completly trivial objection. Your patch made the above > code snippet quite a lot harder to read (and hence harder to maintain). Initially, I proposed following patch to Christoph. but he prefer n and m. To be honest, I don't think this naming is big matter. so you prefer following I'll submit it. ===================================================================== >From 397199d69860061eaa5e1aaadac45c46c76b0522 Mon Sep 17 00:00:00 2001 From: KOSAKI Motohiro <kosaki.motohiro@xxxxxxxxxxxxxx> Date: Wed, 30 Jun 2010 13:35:16 +0900 Subject: [PATCH] vmscan: don't subtraction of unsined 'slab_reclaimable' and 'nr_pages' are unsigned. so, subtraction is unsafe. Signed-off-by: KOSAKI Motohiro <kosaki.motohiro@xxxxxxxxxxxxxx> --- mm/vmscan.c | 15 ++++++++------- 1 files changed, 8 insertions(+), 7 deletions(-) diff --git a/mm/vmscan.c b/mm/vmscan.c index 9c7e57c..79ff877 100644 --- a/mm/vmscan.c +++ b/mm/vmscan.c @@ -2588,7 +2588,7 @@ static int __zone_reclaim(struct zone *zone, gfp_t gfp_mask, unsigned int order) .swappiness = vm_swappiness, .order = order, }; - unsigned long slab_reclaimable; + unsigned long nr_slab_pages0, nr_slab_pages1; disable_swap_token(); cond_resched(); @@ -2615,8 +2615,8 @@ static int __zone_reclaim(struct zone *zone, gfp_t gfp_mask, unsigned int order) } while (priority >= 0 && sc.nr_reclaimed < nr_pages); } - slab_reclaimable = zone_page_state(zone, NR_SLAB_RECLAIMABLE); - if (slab_reclaimable > zone->min_slab_pages) { + nr_slab_pages0 = zone_page_state(zone, NR_SLAB_RECLAIMABLE); + if (nr_slab_pages0 > zone->min_slab_pages) { /* * shrink_slab() does not currently allow us to determine how * many pages were freed in this zone. So we take the current @@ -2628,16 +2628,17 @@ static int __zone_reclaim(struct zone *zone, gfp_t gfp_mask, unsigned int order) * take a long time. */ while (shrink_slab(sc.nr_scanned, gfp_mask, order) && - zone_page_state(zone, NR_SLAB_RECLAIMABLE) > - slab_reclaimable - nr_pages) + (zone_page_state(zone, NR_SLAB_RECLAIMABLE) + nr_pages > + nr_slab_pages0)) ; /* * Update nr_reclaimed by the number of slab pages we * reclaimed from this zone. */ - sc.nr_reclaimed += slab_reclaimable - - zone_page_state(zone, NR_SLAB_RECLAIMABLE); + nr_slab_pages1 = zone_page_state(zone, NR_SLAB_RECLAIMABLE); + if (nr_slab_pages1 < nr_slab_pages0) + sc.nr_reclaimed += nr_slab_pages0 - nr_slab_pages1; } p->reclaim_state = NULL; -- 1.6.5.2 -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href