On Mon, 21 Jun 2010, KOSAKI Motohiro wrote: > > I disagree that the renaming of the variables is necessary, please simply > > change the while (tsk != start) to use while_each_thread(tsk, start); > > This is common naming rule of while_each_thread(). please grep. > I disagree, there's no sense in substituting variable names like "tsk" for `p' and removing a very clear and obvious "start" task: it doesn't improve code readability. I'm in favor of changing the while (tsk != start) to while_each_thread(tsk, start) which is very trivial to understand and much more readable than while_each_thread(p, tsk). With the latter, it's not clear whether `p' or "tsk" is the iterator and which is the constant. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>