debug_on() is too generic of a name for a slub function, so rename it to the more appropriate cache_debug_on(). Cc: Christoph Lameter <cl@xxxxxxxxx> Signed-off-by: David Rientjes <rientjes@xxxxxxxxxx> --- mm/slub.c | 10 +++++----- 1 files changed, 5 insertions(+), 5 deletions(-) diff --git a/mm/slub.c b/mm/slub.c --- a/mm/slub.c +++ b/mm/slub.c @@ -110,7 +110,7 @@ #define SLAB_DEBUG_FLAGS (SLAB_RED_ZONE | SLAB_POISON | SLAB_STORE_USER | \ SLAB_TRACE | SLAB_DEBUG_FREE) -static inline int debug_on(struct kmem_cache *s) +static inline int cache_debug_on(struct kmem_cache *s) { #ifdef CONFIG_SLUB_DEBUG return unlikely(s->flags & SLAB_DEBUG_FLAGS); @@ -1202,7 +1202,7 @@ static void __free_slab(struct kmem_cache *s, struct page *page) int order = compound_order(page); int pages = 1 << order; - if (debug_on(s)) { + if (cache_debug_on(s)) { void *p; slab_pad_check(s, page); @@ -1433,7 +1433,7 @@ static void unfreeze_slab(struct kmem_cache *s, struct page *page, int tail) stat(s, tail ? DEACTIVATE_TO_TAIL : DEACTIVATE_TO_HEAD); } else { stat(s, DEACTIVATE_FULL); - if (debug_on(s) && (s->flags & SLAB_STORE_USER)) + if (cache_debug_on(s) && (s->flags & SLAB_STORE_USER)) add_full(n, page); } slab_unlock(page); @@ -1640,7 +1640,7 @@ load_freelist: object = c->page->freelist; if (unlikely(!object)) goto another_slab; - if (debug_on(s)) + if (cache_debug_on(s)) goto debug; c->freelist = get_freepointer(s, object); @@ -1799,7 +1799,7 @@ static void __slab_free(struct kmem_cache *s, struct page *page, stat(s, FREE_SLOWPATH); slab_lock(page); - if (debug_on(s)) + if (cache_debug_on(s)) goto debug; checks_ok: -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>