> > + /* > > + * If we need a large contiguous chunk of memory, or have > > + * trouble getting a small set of contiguous pages, we > > + * will reclaim both active and inactive pages. > > + */ > > + if (sc->order > PAGE_ALLOC_COSTLY_ORDER) > > + sc->lumpy_reclaim = 1; > > + else if (sc->order && priority < DEF_PRIORITY - 2) > > + sc->lumpy_reclaim = 1; > > + else > > + sc->lumpy_reclaim = 0; > > How about making new function for readability instead of nesting else? > int is_lumpy_reclaim(struct scan_control *sc) > { > .... > } > > If you merge patch reduced stack usage of reclaim path, I think it's > enough alone scan_control argument. > It's just nitpick. :) > If you don't mind, ignore, please. Good opinion. I don't hope introduce the dependency of "reduced stack usage" series. but I agree that I'll push your proposal later and separately. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@xxxxxxxxxx For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@xxxxxxxxx"> email@xxxxxxxxx </a>