Re: [PATCH RESEND v9 0/2] Add support for Loongson1 APB DMA

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi, Keguang,

I accept your suggestion about the cpufreq driver naming, and now it
is upstream:
https://git.kernel.org/pub/scm/linux/kernel/git/vireshk/pm.git/commit/?h=cpufreq/arm/linux-next&id=ccf51454145bffd98e31cdbe54a4262473c609e2

I still hope you can accept my suggestion about the dma driver naming.

I know you hope me rename LS2X_APB_DMA to LOONGSON2_APB_DMA, but as I
said before, renaming an existing Kconfig option will break config
files.

See an example:
Commit a50a3f4b6a313dc76912bd4ad3b8b4f4b4 introduce PREEMPT_RT and
rename PREEMPT to PREEMPT_LL, but then commit
b8d3349803ba34afda429e87a837fd95a9 rename it back because of config
files broken.


Huacai

On Thu, Jul 11, 2024 at 6:57 PM Keguang Zhang via B4 Relay
<devnull+keguang.zhang.gmail.com@xxxxxxxxxx> wrote:
>
> Add the driver and dt-binding document for Loongson1 APB DMA.
>
> ---
> Changes in v9:
> - Fix all the errors and warnings when building with W=1 and C=1
> - Link to v8: https://lore.kernel.org/r/20240607-loongson1-dma-v8-0-f9992d257250@xxxxxxxxx
>
> Changes in v8:
> - Change 'interrupts' property to an items list
> - Link to v7: https://lore.kernel.org/r/20240329-loongson1-dma-v7-0-37db58608de5@xxxxxxxxx
>
> Changes in v7:
> - Change the comptible to 'loongson,ls1*-apbdma' (suggested by Huacai Chen)
> - Update the title and description part accordingly
> - Rename the file to loongson,ls1b-apbdma.yaml
> - Add a compatible string for LS1A
> - Delete minItems of 'interrupts'
> - Change patterns of 'interrupt-names' to const
> - Rename the file to loongson1-apb-dma.c to keep the consistency
> - Update Kconfig and Makefile accordingly
> - Link to v6: https://lore.kernel.org/r/20240316-loongson1-dma-v6-0-90de2c3cc928@xxxxxxxxx
>
> Changes in v6:
> - Change the compatible to the fallback
> - Implement .device_prep_dma_cyclic for Loongson1 sound driver,
> - as well as .device_pause and .device_resume.
> - Set the limitation LS1X_DMA_MAX_DESC and put all descriptors
> - into one page to save memory
> - Move dma_pool_zalloc() into ls1x_dma_alloc_desc()
> - Drop dma_slave_config structure
> - Use .remove_new instead of .remove
> - Use KBUILD_MODNAME for the driver name
> - Improve the debug information
> - Some minor fixes
>
> Changes in v5:
> - Add the dt-binding document
> - Add DT support
> - Use DT information instead of platform data
> - Use chan_id of struct dma_chan instead of own id
> - Use of_dma_xlate_by_chan_id() instead of ls1x_dma_filter()
> - Update the author information to my official name
>
> Changes in v4:
> - Use dma_slave_map to find the proper channel.
> - Explicitly call devm_request_irq() and tasklet_kill().
> - Fix namespace issue.
> - Some minor fixes and cleanups.
>
> Changes in v3:
> - Rename ls1x_dma_filter_fn to ls1x_dma_filter.
>
> Changes in v2:
> - Change the config from 'DMA_LOONGSON1' to 'LOONGSON1_DMA',
> - and rearrange it in alphabetical order in Kconfig and Makefile.
> - Fix comment style.
>
> ---
> Keguang Zhang (2):
>       dt-bindings: dma: Add Loongson-1 APB DMA
>       dmaengine: Loongson1: Add Loongson-1 APB DMA driver
>
>  .../bindings/dma/loongson,ls1b-apbdma.yaml         |  67 +++
>  drivers/dma/Kconfig                                |   9 +
>  drivers/dma/Makefile                               |   1 +
>  drivers/dma/loongson1-apb-dma.c                    | 665 +++++++++++++++++++++
>  4 files changed, 742 insertions(+)
> ---
> base-commit: d35b2284e966c0bef3e2182a5c5ea02177dd32e4
> change-id: 20231120-loongson1-dma-163afe5708b9
>
> Best regards,
> --
> Keguang Zhang <keguang.zhang@xxxxxxxxx>
>
>
>





[Index of Archives]     [LKML Archive]     [Linux ARM Kernel]     [Linux ARM]     [Git]     [Yosemite News]     [Linux SCSI]     [Linux Hams]

  Powered by Linux