From: Sergio Paracuellos > Sent: 10 April 2024 11:44 > On Tue, Apr 9, 2024 at 5:36 PM Thorsten Blum <thorsten.blum@xxxxxxxxxx> wrote: > > > > Fixes the following Coccinelle/coccicheck warning reported by > > minmax.cocci: > > > > WARNING opportunity for min() > > > > Signed-off-by: Thorsten Blum <thorsten.blum@xxxxxxxxxx> > > --- > > arch/mips/ralink/timer.c | 6 +----- > > 1 file changed, 1 insertion(+), 5 deletions(-) > > > > diff --git a/arch/mips/ralink/timer.c b/arch/mips/ralink/timer.c > > index 54094f6e033e..d271ac98312a 100644 > > --- a/arch/mips/ralink/timer.c > > +++ b/arch/mips/ralink/timer.c > > @@ -75,11 +75,7 @@ static int rt_timer_request(struct rt_timer *rt) > > > > static int rt_timer_config(struct rt_timer *rt, unsigned long divisor) I doubt 'unsigned long' is the best type there. It should probably be u32 - so still 32bit on 64bit systems. > > { > > - if (rt->timer_freq < divisor) > > - rt->timer_div = rt->timer_freq; > > - else > > - rt->timer_div = divisor; > > - > > + rt->timer_div = min(rt->timer_freq, divisor); > > I do find the original code more readable. Probably because it isn't really a 'min()' but avoiding a division generating a quotient of zero. It might be better to explicitly avoid the x/x below. David > > Best regards, > Sergio Paracuellos > > > rt_timer_w32(rt, TIMER_REG_TMR0LOAD, rt->timer_freq / rt->timer_div); > > > > return 0; > > -- > > 2.44.0 > > - Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK Registration No: 1397386 (Wales)