On Wed, Sep 13, 2023, Sean Christopherson wrote: > virt/kvm/guest_mem.c | 593 +++++++++++++++++++++++++++++++++++++ Getting to the really important stuff... Anyone object to naming the new file guest_memfd.c instead of guest_mem.c? Just the file, i.e. still keep the gmem namespace. Using guest_memfd.c would make it much more obvious that the file holds more than generic "guest memory" APIs, and would provide a stronger conceptual connection with memfd.c.