On Mon, 2021-11-15 at 20:26 +0100, Paolo Bonzini wrote: > > > Also, for the small requests: since you are at it, can you add the code > > > in a new file under virt/kvm/? > > > > Hm... only if I can make hva_to_pfn() and probably a handful of other > > things non-static? > > Yes, I think sooner or later we also want all pfn stuff in one file > (together with MMU notifiers) and all hva stuff in another; so for now > you can create virt/kvm/hva_to_pfn.h, or virt/kvm/mm.h, or whatever > color of the bikeshed you prefer. OK... let's start with this. David Woodhouse (7): KVM: Introduce CONFIG_HAVE_KVM_DIRTY_RING KVM: Add Makefile.kvm for common files, use it for x86 KVM: s390: Use Makefile.kvm for common files KVM: mips: Use Makefile.kvm for common files KVM: RISC-V: Use Makefile.kvm for common files KVM: powerpc: Use Makefile.kvm for common files KVM: arm64: Use Makefile.kvm for common files arch/arm64/kvm/Makefile | 6 ++---- arch/mips/kvm/Makefile | 3 ++- arch/powerpc/kvm/Makefile | 6 +----- arch/riscv/kvm/Makefile | 6 +----- arch/s390/kvm/Makefile | 6 ++---- arch/x86/kvm/Kconfig | 1 + arch/x86/kvm/Makefile | 7 +------ include/linux/kvm_dirty_ring.h | 8 ++++---- virt/kvm/Kconfig | 3 +++ virt/kvm/Makefile.kvm | 13 +++++++++++++ virt/kvm/kvm_main.c | 4 ++-- 11 files changed, 32 insertions(+), 31 deletions(-)
Attachment:
smime.p7s
Description: S/MIME cryptographic signature