Hello, On Saturday 15 August 2015 00:08:55 Sakari Ailus wrote: > On Fri, Aug 14, 2015 at 11:56:39AM -0300, Mauro Carvalho Chehab wrote: > ... > > > diff --git a/include/media/media-entity.h b/include/media/media-entity.h > > index 8b21a4d920d9..478d5cd56be9 100644 > > --- a/include/media/media-entity.h > > +++ b/include/media/media-entity.h > > @@ -126,6 +126,8 @@ struct media_entity_graph { > > int top; > > }; > > > > +#define entity_id(entity) ((entity)->id) > > + > > int media_entity_init(struct media_entity *entity, u16 num_pads, > > struct media_pad *pads); > > > > void media_entity_cleanup(struct media_entity *entity); > > media-entity.h is a pretty widely included header file. Perhaps we should > think about the naming a bit. > > All the other names in the header begin with media (or __media); I'd very > much prefer not changing that pattern. I'd prefer naming it media_entity_id() as well. Slightly nitpicking, wouldn't it also be better to make it a static inline function instead of a macro to ensure type safety ? No strong preference though. -- Regards, Laurent Pinchart -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html