Hi Sakari, On 09/03/15 11:57, Sakari Ailus wrote: >>> +static struct mt9v032_platform_data * >>> +mt9v032_get_pdata(struct i2c_client *client) >>> +{ >>> + struct mt9v032_platform_data *pdata; >>> + struct v4l2_of_endpoint endpoint; >>> + struct device_node *np; >>> + struct property *prop; >>> + >>> + if (!IS_ENABLED(CONFIG_OF) || !client->dev.of_node) >>> + return client->dev.platform_data; >>> + >>> + np = v4l2_of_get_next_endpoint(client->dev.of_node, NULL); >>> + if (!np) >>> + return NULL; >>> + >>> + if (v4l2_of_parse_endpoint(np, &endpoint) < 0) >>> + goto done; >>> + >>> + pdata = devm_kzalloc(&client->dev, sizeof(*pdata), GFP_KERNEL); >>> + if (!pdata) >>> + goto done; >>> + >>> + prop = of_find_property(np, "link-freqs", NULL); >> >> I suspect you meant "link-frequencies" here ? > > Yes. I wonder if it'd make sense to add this to struct v4l2_of_endpoint. I > can write a patch for that. I don't have strong preference, sooner or later we will need to add it there, so code duplication can be avoided. I guess it makes sense to add such code already with a first user of it. >>> + if (prop) { >>> + size_t size = prop->length / 8; >>> + u64 *link_freqs; >>> + >>> + link_freqs = devm_kzalloc(&client->dev, >>> + size * sizeof(*link_freqs), >>> + GFP_KERNEL); >>> + if (!link_freqs) >>> + goto done; >>> + >>> + if (of_property_read_u64_array(np, "link-frequencies", >>> + link_freqs, size) < 0) >>> + goto done; >>> + >>> + pdata->link_freqs = link_freqs; >>> + pdata->link_def_freq = link_freqs[0]; >>> + } > > If you're interested in just a single value, you can use > of_property_read_u64(). > >>> + pdata->clk_pol = !!(endpoint.bus.parallel.flags & >>> + V4L2_MBUS_PCLK_SAMPLE_RISING); >>> + >>> +done: >>> + of_node_put(np); >>> + return pdata; >>> +} -- Regards, Sylwester -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html