RE: [PATCH v2 23/29] [media] coda: use prescan_failed variable to stop stream after a timeout

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

> From: Philipp Zabel [mailto:p.zabel@xxxxxxxxxxxxxx]
> Sent: Tuesday, June 24, 2014 4:56 PM
> To: linux-media@xxxxxxxxxxxxxxx
> Cc: Mauro Carvalho Chehab; Kamil Debski; Fabio Estevam;
> kernel@xxxxxxxxxxxxxx; Philipp Zabel
> Subject: [PATCH v2 23/29] [media] coda: use prescan_failed variable to
> stop stream after a timeout
> 
> This variable should be renamed to hold instead (temporarily stopping
> streaming until new data is fed into the bitstream buffer).

Could you explain this commit message to me? If the name should be changed
then why isn't it done in this patch or any subsequent patches?

> 
> Signed-off-by: Philipp Zabel <p.zabel@xxxxxxxxxxxxxx>
> ---
>  drivers/media/platform/coda.c | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/drivers/media/platform/coda.c
> b/drivers/media/platform/coda.c index 4548c84..cded081 100644
> --- a/drivers/media/platform/coda.c
> +++ b/drivers/media/platform/coda.c
> @@ -1423,6 +1423,8 @@ static void coda_pic_run_work(struct work_struct
> *work)
> 
>  	if (!wait_for_completion_timeout(&ctx->completion,
> msecs_to_jiffies(1000))) {
>  		dev_err(&dev->plat_dev->dev, "CODA PIC_RUN timeout\n");
> +
> +		ctx->prescan_failed = true;
>  	} else if (!ctx->aborting) {
>  		if (ctx->inst_type == CODA_INST_DECODER)
>  			coda_finish_decode(ctx);
> --
> 2.0.0

Best wishes,
-- 
Kamil Debski
Samsung R&D Institute Poland

--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux