Re: [yavta PATCH 5/9] Allow passing file descriptors to yavta

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Laurent,

Thanks for the comments.

Laurent Pinchart wrote:
...
@@ -196,6 +192,16 @@ static int video_open(struct device *dev, const char
*devname, int no_query)

  	printf("Device %s opened.\n", devname);

+	dev->opened = 1;
+
+	return 0;
+}
+
+static int video_querycap(struct device *dev, int no_query) {
+	struct v4l2_capability cap;
+	unsigned int capabilities;
+	int ret;
+

video_querycap ends up setting the dev->type field, which isn't really the job
of a query function. Would there be a clean way to pass the fd to the
video_open() function instead ? Maybe video_open() could be split and/or
renamed to video_init() ?

Agreed. I'll separate queue type selection from querycap. As the querycap needs to be done after opening the device, I'll put it into another function. I'm ok with video_init(), but what would you think about e.g. video_set_queue_type() as the function does nothing else.

--
Regards,

Sakari Ailus
sakari.ailus@xxxxxx
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux