On 15.12.2013 13:30, Mauro Carvalho Chehab wrote:
Em Sat, 14 Dec 2013 19:47:45 +0200
Antti Palosaari <crope@xxxxxx> escreveu:
On 14.12.2013 19:05, Hans Verkuil wrote:
On 12/14/2013 05:45 PM, Antti Palosaari wrote:
I didn't like much that now have 3 ways to describe frequencies.
I think we should latter think on moving the frequency conversion to
the core, and use u64 with 1Hz step at the internal API, converting all
the drivers to use it.
IMHO, we should also provide a backward-compatible way that would allow
userspace to choose to use u64 1-Hz-stepping frequencies.
Of course the changes at the drivers is out of the scope, but perhaps
we should not apply patch 4/7, replacing it, instead, by some patch that
would move the frequency size to u64.
Frequency is defined by that structure.
struct v4l2_frequency {
__u32 tuner;
__u32 type; /* enum v4l2_tuner_type */
__u32 frequency;
__u32 reserved[8];
};
Is it possible to somehow use reserved bytes to extend value to 64. Then
change that 1-Hz flag (rename it) to signal it is 64?
Or add some info to that struct itself? Define both frequency and
frequency64 and use the one which is not zero?
If implementation will not be very complex I could try to do it it the
same time with other changes.
regards
Antti
--
http://palosaari.fi/
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html