Hi Kamil, On Tue, Jun 25, 2013 at 7:33 PM, Kamil Debski <k.debski@xxxxxxxxxxx> wrote: > Hi Arun, > > This patch sets looks very good. > Please check my comments below. > >> From: Arun Kumar K [mailto:arun.kk@xxxxxxxxxxx] >> >> Firmware version v7 is mostly similar to v6 in terms of hardware >> specific controls and commands. So the hardware specific opr_v6 and >> cmd_v6 are re-used for v7 also. This patch updates the v6 files to >> handle v7 version also. >> >> Signed-off-by: Arun Kumar K <arun.kk@xxxxxxxxxxx> >> --- >> drivers/media/platform/s5p-mfc/s5p_mfc_enc.c | 11 ++++- >> drivers/media/platform/s5p-mfc/s5p_mfc_opr_v6.c | 53 >> +++++++++++++++++++---- >> 2 files changed, 53 insertions(+), 11 deletions(-) >> >> diff --git a/drivers/media/platform/s5p-mfc/s5p_mfc_enc.c >> b/drivers/media/platform/s5p-mfc/s5p_mfc_enc.c >> index f734ccc..dd57b06 100644 >> --- a/drivers/media/platform/s5p-mfc/s5p_mfc_enc.c >> +++ b/drivers/media/platform/s5p-mfc/s5p_mfc_enc.c >> @@ -1663,8 +1663,15 @@ static int s5p_mfc_queue_setup(struct vb2_queue >> *vq, >> if (*buf_count > MFC_MAX_BUFFERS) >> *buf_count = MFC_MAX_BUFFERS; >> >> - psize[0] = ctx->luma_size; >> - psize[1] = ctx->chroma_size; >> + if (IS_MFCV7(dev)) { >> + /* MFCv7 needs pad bytes for input YUV */ >> + psize[0] = ctx->luma_size + 256; >> + psize[1] = ctx->chroma_size + 128; > > Here, I would add some define name to avoid magic number. > Secondly, why wasn't this padding added in s5p_mfc_enc_calc_src_size_v6/v7? > enc_calc_src_size is called in s_fmt, so it seems the best place to adjust > buffer/plane sizes. > Yes that seems to be the right place to make this change. Will change it in next version. Regards Arun -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html