(CCed Steven Toth and Devin Heitmueller) On Tue, Oct 23, 2012 at 7:16 PM, Andy Walls <awalls@xxxxxxxxxxxxxxxx> wrote: > On Tue, 2012-10-23 at 16:57 -0300, Ezequiel Garcia wrote: >> This kind of memcpy() is error-prone. Its replacement with a struct >> assignment is prefered because it's type-safe and much easier to read. >> >> Found by coccinelle. Hand patched and reviewed. >> Tested by compilation only. >> >> A simplified version of the semantic match that finds this problem is as >> follows: (http://coccinelle.lip6.fr/) >> >> // <smpl> >> @@ >> identifier struct_name; >> struct struct_name to; >> struct struct_name from; >> expression E; >> @@ >> -memcpy(&(to), &(from), E); >> +to = from; >> // </smpl> >> >> Signed-off-by: Peter Senna Tschudin <peter.senna@xxxxxxxxx> >> Signed-off-by: Ezequiel Garcia <elezegarcia@xxxxxxxxx> > > This patch looks OK to me. You forgot to CC: Steven Toth and/or Devin > Heitmueller (I can't remember who did the VBI work.) Done, thank you. Ezequiel -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html