Some people thought that it would be nice to have the macros rather than
the inlined field initializations, especially since there is no flag for
write. A separate question is whether an array of one element is useful,
or whether one should systematically use & on a simple variable of the
structure type. I'm open to suggestions about either point.
I think the macro naming is not great.
Maybe add DEFINE_/DECLARE_/_INIT or something other than an action
name type to the macro names.
DEFINE and DECLARE usually have a declared variable as an argument, which
is not the case here.
These macros are like the macros PCI_DEVICE and PCI_DEVICE_CLASS.
Are READ and WRITE the action names? They are really the important
information in this case.
I think the consistency is better if all the references are done
as arrays, even for single entry arrays.
Is it worth creating arrays where &msg is used? Or would it be better to
leave that aspect as it is?
julia
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html