On Wed, Sep 12, 2012 at 05:50:54PM +0200, Peter Senna Tschudin wrote: > Marcos, > > > Now that you removed this kfree, you could remove this label too. Very > > nice your cleanup :) > Thanks! > > > > >> vpbe_fail_sd_register: > >> kfree(vpbe_dev->encoders); > >> vpbe_fail_v4l2_device: > > The problem removing the label is that it will require some more work > naming the labels. See: > if (!vpbe_dev->amp) { > ... > goto vpbe_fail_amp_register; > > If I just remove the label vpbe_fail_amp_register, the label names > will not make sense any more as the next label is > vpbe_fail_sd_register. So I will need to change the name to something > different or rename all labels to out1, out2, out3 or err1, err2, > err3, or .... > > Any suggestions? Labal names should not be numbers because this is not GW-BASIC. The label should reflect what happens on the next line. Labeling the place after the goto location where you started from is always nonsense. regards, dan carpenter -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html