On 08/11/2012 03:31 AM, Manu Abraham wrote:
On Sat, Aug 11, 2012 at 5:44 AM, Antti Palosaari <crope@xxxxxx> wrote:
On 08/11/2012 01:12 AM, Mauro Carvalho Chehab wrote:
Em 13-07-2012 20:15, CrazyCat escreveu:
#define DTV_ISDBS_TS_ID 42
#define DTV_DVBT2_PLP_ID 43
+#define DTV_DVBS2_MIS_ID 43
It would be better to define it as:
#define DTV_DVBS2_MIS_ID DTV_DVBT2_PLP_ID
Even better, we should instead find a better name that would cover both
DVB-T2 and DVB-S2 program ID fields, like:
#define DTV_DVB_MULT 43
#define DTV_DVBT2_PLP_ID DTV_DVB_MULT
And use the new symbol for both DVB-S2 and DVB-T2, deprecating the
legacy symbol.
Also DTV_ISDBS_TS_ID means same. All these three DTV_ISDBS_TS_ID,
DTV_DVBT2_PLP_ID and DTV_DVBS2_MIS_ID are same thing - just named
differently between standards. I vote for common name TS ID (I have said
that already enough many times...).
I agree, but a still more generic term like STREAM_ID would be more
appropriate,
Ack. Since this stream could be something else than MPEG2-TS better to
give more generic name.
as it happens at different layers for different delivery
systems.DVB-S2 additionally
provides BBHEADER at Physical Layer. In any case setting PLP_ID for DVB-S2
is completely confusing.
Anyway, the demuxer part is also missing ..
Demuxer for MIS? I am not any familiar with MIS but I know there is
"raw" demux payload used already for ATSC-M/H. It just passes all the
data coming from demod "TS".
If you look a bit more deeper, you will see that the framing structure
with ISDB-T
is exactly the same as with ISDB-S, which makes ISDB-T also no different, just
that the frontend userspace header is just fucked up with junk.
The major chunk for the ISDB-T stuff in the frontend header is
completely redundant.
Regards,
Manu
regards
Antti
--
http://palosaari.fi/
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html