On Friday 25 February 2011 10:54:02 Hans Verkuil wrote: > On Friday, February 25, 2011 10:21:59 Laurent Pinchart wrote: > > On Friday 25 February 2011 07:21:27 Kim, HeungJun wrote: > > > Support more modes of autofocus, it changes the type of > > > V4L2_CID_FOCUS_AUTO from boolean to menu. And it includes 4 kinds of > > > enumeration types: > > > > > > V4L2_FOCUS_AUTO, V4L2_FOCUS_MANUAL, V4L2_FOCUS_MACRO, > > > V4L2_FOCUS_CONTINUOUS > > > > > > Signed-off-by: Heungjun Kim <riverful.kim@xxxxxxxxxxx> > > > Signed-off-by: Kyungmin Park <kyungmin.park@xxxxxxxxxxx> > > > --- > > > > > > drivers/media/video/v4l2-ctrls.c | 11 ++++++++++- > > > include/linux/videodev2.h | 6 ++++++ > > > 2 files changed, 16 insertions(+), 1 deletions(-) > > > > > > diff --git a/drivers/media/video/v4l2-ctrls.c > > > b/drivers/media/video/v4l2-ctrls.c index 2412f08..0b1cce0 100644 > > > --- a/drivers/media/video/v4l2-ctrls.c > > > +++ b/drivers/media/video/v4l2-ctrls.c > > > @@ -197,6 +197,13 @@ const char * const *v4l2_ctrl_get_menu(u32 id) > > > > > > "Aperture Priority Mode", > > > NULL > > > > > > }; > > > > > > + static const char * const camera_focus_auto[] = { > > > + "Manual Mode", > > > + "Auto Mode", > > > + "Macro Mode", > > > + "Continuous Mode", > > > > This might be nit-picking, but maybe the menu entries should be named > > "Manual Focus", "Auto Focus", "Macro Focus" and "Continuous Auto Focus". > > Hans ? > > Yes, that's better. Although I believe that it should be 'Macro Auto > Focus', right? I suppose so. Heungjun could confirm that. > But if we change this for 'focus' then we need to do the same for the auto > exposure menu which currently also uses the term 'Mode'. > > Do you agree? Auto Mode and Manual Mode could be renamed to Auto Exposure and Manual Exposure, but Shutter Priority Exposure and Aperture Priority Exposure don't sound right. -- Regards, Laurent Pinchart -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html