Refactor the camss_link_entities function by breaking it down into three distinct functions. Each function will handle the linking of a specific entity separately, enhancing readability. Changes in V3: - Broke down the change in 2 patches. first one to functionally decompose link error message. second to restrcture the link function. - Removed the declarion of camss_link_error from header file. - Link to v2: https://lore.kernel.org/linux-arm-msm/20241112133846.2397017-1-quic_vikramsa@xxxxxxxxxxx/ Changes in V2: - Declared variables in reverse christmas tree order. - Functionally decomposed link error message. - Link to v1: https://lore.kernel.org/linux-arm-msm/20241111173845.1773553-1-quic_vikramsa@xxxxxxxxxxx/ To: Robert Foss <rfoss@xxxxxxxxxx> To: Todor Tomov <todor.too@xxxxxxxxx> To: Bryan O'Donoghue <bryan.odonoghue@xxxxxxxxxx> Cc: linux-media@xxxxxxxxxxxxxxx Cc: linux-kernel@xxxxxxxxxxxxxxx Signed-off-by: Vikram Sharma <quic_vikramsa@xxxxxxxxxxx> Vikram Sharma (2): media: qcom: camss: reducing the repitious error message string media: qcom: camss: Restructure camss_link_entities drivers/media/platform/qcom/camss/camss.c | 195 ++++++++++++++-------- 1 file changed, 130 insertions(+), 65 deletions(-) -- 2.25.1