On Fri, Nov 22, 2024 at 09:28:53AM +0000, CK Hu (胡俊光) wrote: > On Fri, 2024-11-22 at 10:16 +0100, Julien Stephan wrote: > > Le ven. 22 nov. 2024 à 08:54, CK Hu (胡俊光) a écrit : > > > On Thu, 2024-11-21 at 09:53 +0100, Julien Stephan wrote: > > > > External email : Please do not click links or open attachments until you have verified the sender or the content. > > > > > > > > > > > > From: Phi-bang Nguyen <pnguyen@xxxxxxxxxxxx> > > > > > > > > This driver provides a path to bypass the SoC ISP so that image data > > > > coming from the SENINF can go directly into memory without any image > > > > processing. This allows the use of an external ISP. > > > > > > > > Signed-off-by: Phi-bang Nguyen <pnguyen@xxxxxxxxxxxx> > > > > Signed-off-by: Florian Sylvestre <fsylvestre@xxxxxxxxxxxx> > > > > [Paul Elder fix irq locking] > > > > Signed-off-by: Paul Elder <paul.elder@xxxxxxxxxxxxxxxx> > > > > Co-developed-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > > > > Co-developed-by: Julien Stephan <jstephan@xxxxxxxxxxxx> > > > > Signed-off-by: Julien Stephan <jstephan@xxxxxxxxxxxx> > > > > --- > > > > > > [snip] > > > > > > > +static void mtk_cam_cmos_vf_enable(struct mtk_cam_dev *cam_dev, > > > > + bool enable, bool pak_en) > > > > +{ > > > > + if (enable) > > > > + cam_dev->hw_functions->mtk_cam_cmos_vf_hw_enable(cam_dev); > > > > > > Directly call mtk_camsv30_cmos_vf_hw_enable(). > > > This has discussed in previous version [1]. > > > > > > [1] https://patchwork.kernel.org/project/linux-mediatek/patch/20240729-add-mtk-isp-3-0-support-v6-4-c374c9e0c672@xxxxxxxxxxxx/ > > > > Hi CK, > > > > I forgot about that discussion sorry :/ > > I guess you want me to completely remove the mtk_cam_hw_functions struct? > > In that case, what do you prefer: > > - keep mtk_camsv30_hw.c and put signatures in mtkcamsv30_hw.h and > > include mtk_camsv30_hw.h in mtk_camsv_video.c > > - rename mtk_camsv30_hw.c to mtk_camsv_hw.c (and all functions) and > > put signatures in mtk_camsv_hw.h > > I prefer the second one. If we drop the indirection (which I think is a good idea until we get a second hardware generation supported by the same driver) I would also go for the latter. > > > > + else > > > > + cam_dev->hw_functions->mtk_cam_cmos_vf_hw_disable(cam_dev); > > > > +} > > > > + > > > > -- Regards, Laurent Pinchart