Hi, Shu-hsiang: On Wed, 2024-10-09 at 19:15 +0800, Shu-hsiang Yang wrote: > Introduces the top media device driver for the MediaTek ISP7X CAMSYS. > The driver maintains the camera system, including sub-device management, > DMA operations, and integration with the V4L2 framework. It handles > request stream data, buffer management, and MediaTek-specific features, > and pipeline management, streaming control, error handling mechanism. > Additionally, it aggregates sub-drivers for the camera interface, raw > and yuv pipelines. > > Signed-off-by: Shu-hsiang Yang <Shu-hsiang.Yang@xxxxxxxxxxxx> > --- [snip] > +struct mtk_cam_request_stream_data * > +mtk_cam_get_req_s_data(struct mtk_cam_ctx *ctx, unsigned int pipe_id, > + unsigned int frame_seq_no) > + > +{ > + struct mtk_cam_device *cam = ctx->cam; > + struct mtk_cam_request *req, *req_prev; > + struct mtk_cam_request_stream_data *req_stream_data; > + int i; > + > + spin_lock(&cam->running_job_lock); > + list_for_each_entry_safe(req, req_prev, &cam->running_job_list, list) { > + if (req->pipe_used & (1 << pipe_id)) { > + for (i = 0; i < req->p_data[pipe_id].s_data_num; i++) { > + req_stream_data = &req->p_data[pipe_id].s_data[i]; > + if (req_stream_data->frame_seq_no == frame_seq_no) { > + spin_unlock(&cam->running_job_lock); > + return req_stream_data; > + } > + } > + } > + } > + spin_unlock(&cam->running_job_lock); > + > + return NULL; > +} > + > +struct mtk_cam_request *mtk_cam_get_req(struct mtk_cam_ctx *ctx, > + unsigned int frame_seq_no) > +{ > + struct mtk_cam_request_stream_data *req_stream_data; > + > + req_stream_data = mtk_cam_get_req_s_data(ctx, ctx->stream_id, frame_seq_no); In some place, it is called 'stream_id'. In some place, it is called 'pipe_id'. It's easy to confuse us that stream_id and pipe_id are different and the code readability is bad. Use the unique name so that we would not get confused. Regards, CK > + if (!req_stream_data) > + return NULL; > + > + return req_stream_data->req; > +} > +