Hi all, we've had a long standing problems where drivers try to hook into the DMA_OPS mechanisms to override them for something that is not DMA, or to introduce additional dispatching. Now that we are not using DMA_OPS support for dma-iommu and can build kernels without DMA_OPS support on many common setups this becomes even more problematic. This series renames the option to ARCH_HAS_DMA_OPS and adds very explicit comment to not use it in drivers. The ipu6 and vdpa_sim/user drivers that abuse the mechanism are made to depend on the option instead of selecting it with a big comment, but I expect this to be fixed rather sooner than later (I know the ipu6 maintainers are on it based on a previous discussion). Changes since v1: - s/ARCH_DMA_OPS/ARCH_HAS_DMA_OPS/g - spelling fixes - vdpa_sim actually doesn't need dma ops these days, add a prep patch to remove the dependency