Re: [PATCH 2/4] media: subdev: Fix use of sd->enabled_streams in call_s_stream()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 04/04/2024 16:00, Laurent Pinchart wrote:
Hi Tomi,

Thank you for the patch.

On Thu, Apr 04, 2024 at 01:50:01PM +0300, Tomi Valkeinen wrote:
call_s_stream() uses sd->enabled_streams to track whether streaming has
already been enabled. However,
v4l2_subdev_enable/disable_streams_fallback(), which was the original
user of this field, already uses it, and
v4l2_subdev_enable/disable_streams_fallback() will call call_s_stream().

This leads to a conflict as both functions set the field. Afaics, both
functions set the field to the same value, so it won't cause a runtime
bug, but it's still wrong and if we, e.g., change how
v4l2_subdev_enable/disable_streams_fallback() operates we might easily
cause bugs.

Fix this by adding a new field, 'streaming_enabled', for
call_s_stream().

Signed-off-by: Tomi Valkeinen <tomi.valkeinen@xxxxxxxxxxxxxxxx>
---
  drivers/media/v4l2-core/v4l2-subdev.c | 8 ++------
  include/media/v4l2-subdev.h           | 2 ++
  2 files changed, 4 insertions(+), 6 deletions(-)

diff --git a/drivers/media/v4l2-core/v4l2-subdev.c b/drivers/media/v4l2-core/v4l2-subdev.c
index b90b5185e87f..3b3310bce5d4 100644
--- a/drivers/media/v4l2-core/v4l2-subdev.c
+++ b/drivers/media/v4l2-core/v4l2-subdev.c
@@ -404,12 +404,8 @@ static int call_s_stream(struct v4l2_subdev *sd, int enable)
  	 * The .s_stream() operation must never be called to start or stop an
  	 * already started or stopped subdev. Catch offenders but don't return
  	 * an error yet to avoid regressions.
-	 *
-	 * As .s_stream() is mutually exclusive with the .enable_streams() and
-	 * .disable_streams() operation, we can use the enabled_streams field
-	 * to store the subdev streaming state.
  	 */
-	if (WARN_ON(!!sd->enabled_streams == !!enable))
+	if (WARN_ON(!!sd->streaming_enabled == !!enable))
  		return 0;
#if IS_REACHABLE(CONFIG_LEDS_CLASS)
@@ -429,7 +425,7 @@ static int call_s_stream(struct v4l2_subdev *sd, int enable)
  	}
if (!ret)
-		sd->enabled_streams = enable ? BIT(0) : 0;
+		sd->streaming_enabled = !!enable;
return ret;
  }
diff --git a/include/media/v4l2-subdev.h b/include/media/v4l2-subdev.h
index a9e6b8146279..8bd1e3c96d2b 100644
--- a/include/media/v4l2-subdev.h
+++ b/include/media/v4l2-subdev.h
@@ -1043,6 +1043,7 @@ struct v4l2_subdev_platform_data {
   *		     v4l2_subdev_enable_streams() and
   *		     v4l2_subdev_disable_streams() helper functions for fallback
   *		     cases.
+ * @streaming_enabled: Tracks whether streaming has been enabled with s_stream.

Could you extend this to indicate this field can't be used by anything
else than call_s_stream() ?

Yes, I'll add that.

I'm also getting a bit concerned about having multiple fields with
similar purposes. Another option would be to call the .s_stream()

I agree, it's getting slightly complex. The reason is that we support many ways for the subdev to implement these things.

operation directly from the fallback handlers, instead of going through
call_s_stream(). That may be considered as a bit of a hack though.

I thought about the same thing, but I felt it might just make things more complex. However, with my new unsent series, I add the privacy_led code also to the v4l2_subdev_enable_streams() function, so it's even more similar to the call_s_stream.

Maybe I'll try it out and see how it looks like if I call the op directly.

 Tomi

   *
   * Each instance of a subdev driver should create this struct, either
   * stand-alone or embedded in a larger struct.
@@ -1091,6 +1092,7 @@ struct v4l2_subdev {
  	 */
  	struct v4l2_subdev_state *active_state;
  	u64 enabled_streams;
+	bool streaming_enabled;
  };






[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]

  Powered by Linux