On 6.03.2024 12:48 PM, Bryan O'Donoghue wrote: > On 09/02/2024 21:09, Konrad Dybcio wrote: >> "core" is used in multiple contexts when talking about Venus, rename >> the function to save on confusion. >> >> Signed-off-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxx> >> --- >> drivers/media/platform/qcom/venus/pm_helpers.c | 6 +++--- >> 1 file changed, 3 insertions(+), 3 deletions(-) >> >> diff --git a/drivers/media/platform/qcom/venus/pm_helpers.c b/drivers/media/platform/qcom/venus/pm_helpers.c >> index 8bd0ce4ce69d..ac7c83404c6e 100644 >> --- a/drivers/media/platform/qcom/venus/pm_helpers.c >> +++ b/drivers/media/platform/qcom/venus/pm_helpers.c >> @@ -23,7 +23,7 @@ >> static bool legacy_binding; >> -static int core_clks_get(struct venus_core *core) >> +static int venus_clks_get(struct venus_core *core) >> { >> const struct venus_resources *res = core->res; >> struct device *dev = core->dev; >> @@ -294,7 +294,7 @@ static int core_get_v1(struct venus_core *core) >> { >> int ret; >> - ret = core_clks_get(core); >> + ret = venus_clks_get(core); >> if (ret) >> return ret; >> @@ -961,7 +961,7 @@ static int core_get_v4(struct venus_core *core) >> const struct venus_resources *res = core->res; >> int ret; >> - ret = core_clks_get(core); >> + ret = venus_clks_get(core); >> if (ret) >> return ret; >> > > We have vcodec_clks_get(). It seems a bit nit-picky but if you are tidying up the namepsace, then I'd suggest venus_core_clks_get() or vcore_clks_get(). > > Seems more consistent. No, that's not the point, you got confused by the inconsistent namespace :/ These are not any "core clocks", they're either "all clocks except vcodec" or "all clocks", depending on the binding type used Konrad