Re: [PATCH 05/11] drm/mediatek: Rename "mtk_drm_hdmi" to "mtk_hdmi"

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi, Shawn:

On Mon, 2024-02-26 at 16:50 +0800, Shawn Sung wrote:
> From: Hsiao Chien Sung <shawn.sung@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
> 
> Rename all "mtk_drm_hdmi" to "mtk_hdmi":
> - To align the naming rule
> - To reduce the code size

Reviewed-by: CK Hu <ck.hu@xxxxxxxxxxxx>

> 
> Signed-off-by: Hsiao Chien Sung <
> shawn.sung@xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
> ---
>  drivers/gpu/drm/mediatek/mtk_hdmi.c | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_hdmi.c
> b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> index 86133bf16326..d2876da1b43a 100644
> --- a/drivers/gpu/drm/mediatek/mtk_hdmi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_hdmi.c
> @@ -1687,7 +1687,7 @@ static int
> mtk_hdmi_register_audio_driver(struct device *dev)
>  	return 0;
>  }
>  
> -static int mtk_drm_hdmi_probe(struct platform_device *pdev)
> +static int mtk_hdmi_probe(struct platform_device *pdev)
>  {
>  	struct mtk_hdmi *hdmi;
>  	struct device *dev = &pdev->dev;
> @@ -1746,7 +1746,7 @@ static int mtk_drm_hdmi_probe(struct
> platform_device *pdev)
>  	return ret;
>  }
>  
> -static void mtk_drm_hdmi_remove(struct platform_device *pdev)
> +static void mtk_hdmi_remove(struct platform_device *pdev)
>  {
>  	struct mtk_hdmi *hdmi = platform_get_drvdata(pdev);
>  
> @@ -1790,7 +1790,7 @@ static const struct mtk_hdmi_conf
> mtk_hdmi_conf_mt8167 = {
>  	.cea_modes_only = true,
>  };
>  
> -static const struct of_device_id mtk_drm_hdmi_of_ids[] = {
> +static const struct of_device_id mtk_hdmi_of_ids[] = {
>  	{ .compatible = "mediatek,mt2701-hdmi",
>  	  .data = &mtk_hdmi_conf_mt2701,
>  	},
> @@ -1801,14 +1801,14 @@ static const struct of_device_id
> mtk_drm_hdmi_of_ids[] = {
>  	},
>  	{}
>  };
> -MODULE_DEVICE_TABLE(of, mtk_drm_hdmi_of_ids);
> +MODULE_DEVICE_TABLE(of, mtk_hdmi_of_ids);
>  
>  static struct platform_driver mtk_hdmi_driver = {
> -	.probe = mtk_drm_hdmi_probe,
> -	.remove_new = mtk_drm_hdmi_remove,
> +	.probe = mtk_hdmi_probe,
> +	.remove_new = mtk_hdmi_remove,
>  	.driver = {
>  		.name = "mediatek-drm-hdmi",
> -		.of_match_table = mtk_drm_hdmi_of_ids,
> +		.of_match_table = mtk_hdmi_of_ids,
>  		.pm = &mtk_hdmi_pm_ops,
>  	},
>  };




[Index of Archives]     [Linux Input]     [Video for Linux]     [Gstreamer Embedded]     [Mplayer Users]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]

  Powered by Linux