Quoting Hans de Goede (2024-02-17 11:24:36) > Change the generic "ATOMISP_SUBDEV" name to "ATOM ISP" to make clear > that this is the subdev for the ISP itself. > > Signed-off-by: Hans de Goede <hdegoede@xxxxxxxxxx> > --- > drivers/staging/media/atomisp/pci/atomisp_subdev.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/media/atomisp/pci/atomisp_subdev.c b/drivers/staging/media/atomisp/pci/atomisp_subdev.c > index 8253b6faf8cd..822fe7d129e2 100644 > --- a/drivers/staging/media/atomisp/pci/atomisp_subdev.c > +++ b/drivers/staging/media/atomisp/pci/atomisp_subdev.c > @@ -799,7 +799,7 @@ static int isp_subdev_init_entities(struct atomisp_sub_device *asd) > int ret; > > v4l2_subdev_init(sd, &isp_subdev_v4l2_ops); > - sprintf(sd->name, "ATOMISP_SUBDEV"); > + sprintf(sd->name, "ATOM ISP"); Pure bikeshedding, but I'd probably lower the shouting to just "Atom ISP" Either way saying it's a subdev on a subdev isn't much of a value add so Reviewed-by: Kieran Bingham <kieran.bingham@xxxxxxxxxxxxxxxx> > v4l2_set_subdevdata(sd, asd); > sd->flags |= V4L2_SUBDEV_FL_HAS_EVENTS | V4L2_SUBDEV_FL_HAS_DEVNODE; > > -- > 2.43.0 >