Hi Hans, Thanks for your review. > > +static const struct v4l2_ctrl_config npcm_ctrl_rect_count = { > > + .id = V4L2_CID_NPCM_RECT_COUNT, > > + .name = "NPCM Compressed Hextile Rectangle Count", > > This name is too long, it should be max 31 characters. Dropping the "Compressed " part > might be best, I think that word isn't needed. > > > + .type = V4L2_CTRL_TYPE_INTEGER, > > + .min = 0, > > + .max = (MAX_WIDTH / RECT_W) * (MAX_HEIGHT / RECT_H), > > + .step = 1, > > + .def = 0, > > +}; > > With this fixed, and the sparse warnings fixed, it should be ready for merging. OK. Will fix them in the next version. Regards, Marvin