On Sunday, September 26, 2010 18:13:28 Laurent Pinchart wrote: > From: Stanimir Varbanov <svarbanov@xxxxxxxxxx> > > Used for storing subdev information per file handle and hold V4L2 file > handle. > > Signed-off-by: Stanimir Varbanov <svarbanov@xxxxxxxxxx> > Signed-off-by: Antti Koskipaa <antti.koskipaa@xxxxxxxxx> > Signed-off-by: Laurent Pinchart <laurent.pinchart@xxxxxxxxxxxxxxxx> > --- > drivers/media/video/v4l2-subdev.c | 82 +++++++++++++++++++++++++------------ > include/media/v4l2-subdev.h | 25 +++++++++++ > 2 files changed, 80 insertions(+), 27 deletions(-) > > diff --git a/drivers/media/video/v4l2-subdev.c b/drivers/media/video/v4l2-subdev.c > index 731dc12..d2891c1 100644 > --- a/drivers/media/video/v4l2-subdev.c > +++ b/drivers/media/video/v4l2-subdev.c > @@ -30,38 +30,66 @@ > #include <media/v4l2-fh.h> > #include <media/v4l2-event.h> > > +static int subdev_fh_init(struct v4l2_subdev_fh *fh, struct v4l2_subdev *sd) > +{ > + /* Allocate probe format and crop in the same memory block */ > + fh->probe_fmt = kzalloc((sizeof(*fh->probe_fmt) + > + sizeof(*fh->probe_crop)) * sd->entity.num_pads, > + GFP_KERNEL); > + if (fh->probe_fmt == NULL) > + return -ENOMEM; I really don't like the name 'probe' for this. I remember discussing it with you, Laurent, but I can't remember the word I came up with. Can you remember what it was? Regards, Hans -- Hans Verkuil - video4linux developer - sponsored by TANDBERG, part of Cisco -- To unsubscribe from this list: send the line "unsubscribe linux-media" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html