Le lundi 19 décembre 2022 à 16:56 +0100, Benjamin Gaignard a écrit : > Compute the additional required to store motion vectors at requires *space*, requires *buffer* ? I think this is missing a word. > the end of the frames buffers. > > > Signed-off-by: Benjamin Gaignard <benjamin.gaignard@xxxxxxxxxxxxx> > --- > drivers/media/platform/verisilicon/hantro_hw.h | 13 +++++++++++++ > .../media/platform/verisilicon/hantro_postproc.c | 3 +++ > drivers/media/platform/verisilicon/hantro_v4l2.c | 5 +++++ > 3 files changed, 21 insertions(+) > > diff --git a/drivers/media/platform/verisilicon/hantro_hw.h b/drivers/media/platform/verisilicon/hantro_hw.h > index e83f0c523a30..8b3bc7e31395 100644 > --- a/drivers/media/platform/verisilicon/hantro_hw.h > +++ b/drivers/media/platform/verisilicon/hantro_hw.h > @@ -417,6 +417,19 @@ hantro_hevc_mv_size(unsigned int width, unsigned int height) > return width * height / 16; > } > > +static inline unsigned short hantro_av1_num_sbs(unsigned short dimension) > +{ > + return DIV_ROUND_UP(dimension, 64) + 1; Why plus one ? I've tested locally with the logical DIV_ROUND_UP(dimension, 64), and didn't see any difference. It then match hantro_vp_num_sbs(), so can't this be shared ? > +} > + > +static inline size_t > +hantro_av1_mv_size(unsigned int width, unsigned int height) > +{ > + size_t num_sbs = hantro_av1_num_sbs(width) * hantro_av1_num_sbs(height); > + > + return ALIGN(num_sbs * 384, 16) + 512; Shall the magic numbers be turned into defines ? > +} > + > int hantro_g1_mpeg2_dec_run(struct hantro_ctx *ctx); > int rockchip_vpu2_mpeg2_dec_run(struct hantro_ctx *ctx); > void hantro_mpeg2_dec_copy_qtable(u8 *qtable, > diff --git a/drivers/media/platform/verisilicon/hantro_postproc.c b/drivers/media/platform/verisilicon/hantro_postproc.c > index 09d8cf942689..7dc39519a2ee 100644 > --- a/drivers/media/platform/verisilicon/hantro_postproc.c > +++ b/drivers/media/platform/verisilicon/hantro_postproc.c > @@ -213,6 +213,9 @@ int hantro_postproc_alloc(struct hantro_ctx *ctx) > else if (ctx->vpu_src_fmt->fourcc == V4L2_PIX_FMT_HEVC_SLICE) > buf_size += hantro_hevc_mv_size(pix_mp.width, > pix_mp.height); > + else if (ctx->vpu_src_fmt->fourcc == V4L2_PIX_FMT_AV1_FRAME) > + buf_size += hantro_av1_mv_size(pix_mp.width, > + pix_mp.height); nit: Time to turn into a switch or use an ops ? > > for (i = 0; i < num_buffers; ++i) { > struct hantro_aux_buf *priv = &ctx->postproc.dec_q[i]; > diff --git a/drivers/media/platform/verisilicon/hantro_v4l2.c b/drivers/media/platform/verisilicon/hantro_v4l2.c > index 2c7a805289e7..d41dcb108a6d 100644 > --- a/drivers/media/platform/verisilicon/hantro_v4l2.c > +++ b/drivers/media/platform/verisilicon/hantro_v4l2.c > @@ -334,6 +334,11 @@ static int hantro_try_fmt(const struct hantro_ctx *ctx, > pix_mp->plane_fmt[0].sizeimage += > hantro_hevc_mv_size(pix_mp->width, > pix_mp->height); > + else if (ctx->vpu_src_fmt->fourcc == V4L2_PIX_FMT_AV1_FRAME && > + !hantro_needs_postproc(ctx, fmt)) > + pix_mp->plane_fmt[0].sizeimage += > + hantro_av1_mv_size(pix_mp->width, > + pix_mp->height); > } else if (!pix_mp->plane_fmt[0].sizeimage) { > /* > * For coded formats the application can specify