Hi Sakari, On Wed, Sep 21, 2022 at 11:20:12AM +0300, Sakari Ailus wrote: > Hi Hidenori, > > On Wed, Sep 21, 2022 at 05:15:35PM +0900, Hidenori Kobayashi wrote: > > > > +static int __maybe_unused ov8856_runtime_suspend(struct device *dev) > > +{ > > + __ov8856_power_off(dev); > > + > > + return 0; > > +} > > + > > +static int __maybe_unused ov8856_runtime_resume(struct device *dev) > > +{ > > + return __ov8856_power_on(dev); > > +} > > These two functions are redundant now, you can call __ov8856_power_on / > __ov8856_power_off directly. The return type of __ov8856_power_off needs to > be changed to int. You could also remove the underscores from the names at > the same time. Will fix it as above. I just wasn't sure about the policy. Thanks! Best regards, Hidenori