The documentation comment was inserted between the return type and the function name. Reunite the lines. Signed-off-by: Ian Jamison <ian.dev@xxxxxxxxxx> Fixes: db7ee32aa185 ("[media] media-device.h: Improve documentation and update it") --- include/media/media-entity.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/media/media-entity.h b/include/media/media-entity.h index 742918962d46..9bc9a55df71e 100644 --- a/include/media/media-entity.h +++ b/include/media/media-entity.h @@ -1030,7 +1030,6 @@ __must_check media_devnode_create(struct media_device *mdev, * removed. */ void media_devnode_remove(struct media_intf_devnode *devnode); -struct media_link * /** * media_create_intf_link() - creates a link between an entity and an interface @@ -1061,6 +1060,7 @@ struct media_link * * the interface and media_device_register_entity() should be called for the * interface that will be part of the link. */ +struct media_link * __must_check media_create_intf_link(struct media_entity *entity, struct media_interface *intf, u32 flags); -- 2.35.1